Internet Banking For Web
Incident Report for Citizens National Bank
Resolved
This incident has been resolved.
Posted Aug 11, 2020 - 15:55 EDT
Monitoring
We are seeing successful logins and are continuing to monitor the system for performance
Posted Aug 11, 2020 - 12:59 EDT
Investigating
We are investigating an ongoing issue with Internet Banking for Web.
Posted Aug 11, 2020 - 12:50 EDT
This incident affected: Online Banking (Web Banking, Corporate Cash Management).