Internet Banking Service Interruption
Incident Report for Citizens National Bank
Resolved
We are now seeing services back to fully operational but our team remains engaged to ensure stability.
Posted Aug 06, 2020 - 12:59 EDT
Identified
Mobile banking has been brought back online however users may experience some latency. Internet Banking for Web and Corporate Cash Management are still experiencing issues with login.
Posted Aug 06, 2020 - 12:26 EDT
Update
We are continuing to investigate this issue.
Posted Aug 06, 2020 - 12:17 EDT
Investigating
We are investigating an issue that is causing service interruption for CNB Mobile and Internet Banking for web.
Posted Aug 06, 2020 - 12:17 EDT
This incident affected: Online Banking (CNB Mobile Banking, Web Banking, Bill Pay, Corporate Cash Management).