Card Management Feature Not Working
Incident Report for Citizens National Bank
Resolved
This incident has been resolved.
Posted Jan 20, 2021 - 08:26 EST
Investigating
The card management feature in the CNB Mobile app is currently not functioning.
Posted Oct 28, 2020 - 10:53 EDT
This incident affected: Online Banking (CNB Mobile Banking).