Intermittent audio issues with incoming calls.
Incident Report for Citizens National Bank
Resolved
This incident has been resolved.
Posted May 21, 2020 - 07:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 21, 2020 - 07:16 EDT
Investigating
We are investing an audio issue with incoming phone calls. It is intermittent, so if you experience this issue, please hang up and call again.
Posted May 20, 2020 - 11:06 EDT
This incident affected: Telephone Systems (Call Center, Expressline Banking).