Internet Banking for Web
Incident Report for Citizens National Bank
Resolved
This incident has been resolved.
Posted Aug 06, 2020 - 16:49 EDT
Monitoring
We are seeing successful logins and are continuing to monitor the system for performance.
Posted Aug 06, 2020 - 13:28 EDT
Investigating
We are investigating an ongoing issue with Internet Banking for Web.
Posted Aug 06, 2020 - 13:12 EDT
This incident affected: Online Banking (Web Banking, Corporate Cash Management).