Issues with Internet Banking
Incident Report for Citizens National Bank
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 15:37 EDT
Identified
Engineers have been working with internal teams to address internal login and sync issues and believe to have found a cause upstream. Engineers remain engaged and are seeing successful logins at this time.
Posted Sep 13, 2021 - 14:42 EDT
Investigating
We are seeing a severe service degradation with our digital banking platforms. We are working to identify the issue.
Posted Sep 13, 2021 - 14:16 EDT
This incident affected: Online Banking (CNB Mobile Banking, Web Banking).